SAP Knowledge Base Article - Public

2940975 - Error "No item category available" Raised when Requesting "External Pricing" from a C4C Ticket

Symptom

You have created a service ticket in C4C system, while requesting the external pricing you got the following error message: No item category available (Table T184 XXXX NORM ZZZZ)

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the view Work Tickets.
  3. Open the respective ticket and press the button Request External Pricing under the Actions.
  4. You will get the above error message.

Cause

Since the item category is not passed to ERP and automatically determined, the relationship needs to be maintained in the ERP tenant. If the ParentItemID is populated in the ticket item, the higher level item category should also be maintained in ERP.

Resolution

Create the missing table T184 entries in your ERP system via:

1. SPRO (IMG): Sales and Distribution -->Sales -->Sales Documents -->Sales Document Item -->Assign Item Categories.

2. Choose New Entries.

3. Enter Sales Doc. Type as XXXX and Item cat. Group as NORM.

4. Enter Item category as ZZZZ and higher level item category as ZZZZ.

Keywords

C4C, TICKET, No item category available, NORM T184 V1320, , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications 2005