SAP Knowledge Base Article - Public

2941431 - Required Registry entry changes to enable Client-side Outlook Addin

Symptom

The Outlook Addin is installed and it is not visible in the Outlook ribbon.

Even after trying to enable the Addin from the Disabled Items, you are unable to see it in the Outlook ribbon.

Environment

SAP Client-side Outlook Addin and MS Outlook

Reproducing the Issue

  • Install the Outlook Addin
  • However, addin not visible in the Outlook ribbon.
  • You try to enable from the Disabled Items, still it is not appearing.

Cause

Outlook imposes strict time limits for add-ins and this includes 1000 ms for loading, 500 ms for folder switch and for shutdown.
If the add-in exceed this time limit, then Outlook disables the add-in

Resolution

  • Open the Registry editor
  • Navigate to Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Addins\SAPBusinessByDesignOutlookAddIn
  • Change the "LoadBehavior" to 3
  • Again navigate to Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\SAPBusinessByDesignOutlookAddIn
  • Change the "LoadBehavior" to 3

Keywords

KBA , load behaviour , enable client side outlook addin , registry entry clientside outlook addin , LOD-CRM-GW-OUT , Outlook , How To

Product

SAP Cloud for Customer add-ins all versions