Symptom
User's sync is not successful with a message "Canceled (SW0001) SW0001: Synchronization was canceled by user.".
This error message can appear in case sync was actually canceled by user but not only in such case.
Environment
SAP Cloud for Customer Server Side Addin
Cause
These messages can also mean that synchronization was running more than 1h and was canceled automatically by sync engine.
SCC system has internal timeout (1-hour maximum per one sync session) to keep system operable. So in case one hour is not enough to finalize sync tasks, sync sessions will be interrupted (canceled) automatically.
Resolution
There are a few options how to resolve current problem:
Reset Mailbox for affected user via Administration page;
Increase the timeout for sync duration. This can be done on the server-sync back-end, submit a support case through a corresponding channel with details to proceed further.
The first option may not work for those customers who have a lot off objects to sync and big amount of conflicts to resolve during the sync session.
Keywords
KBA , sync canceled by user , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To