SAP Knowledge Base Article - Public

2942021 - When Creating a Ticket, Derive Territory Workflow Rule Does Not Work

Symptom

You have a Workflow rule to, when creating a Ticket, derive the account territory for ticket territory. But it does not work.

Environment

SAP Cloud for Customer

Reproducing the Issue

Create a Workflow Rule:

  1. Business Object is Ticket and the timing is On Create Only. 
  2. Press Next button until Rule Type (do not maintain any conditions groups).
  3. On Rule Type, choose Action and Derive Territory for action. 
  4. Finish.

Now, create a Ticket with an account of your choice and save. See that the territory was not maintained.

Cause

You have not maintained any conditions groups that would trigger the rule.

Resolution

You have to change the Workflow Rule. Add conditions groups using the Account Owner ID (or some field that will be related to the territory). In action, use Update Field to update the Territory field with the Territory ID.

See Also

https://help.sap.com/viewer/cea15f900ca04c4faa35d3044577fe27/1908/en-US/3ee09b583f7d418599178e3a2a0d80d8.html?q=workflow%20rule

Keywords

KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2005