Symptom
Synchronization error is a case, when synchronization becomes completely non-functional, no records can be synchronized.
Environment
SAP Cloud for Customer (Server Side Addin)
Cause
Synchronization error occurs due to authentication issue on Microsoft Exchange:
Resolution
Source |
Message |
Solution |
ExchangeConnector |
Authentication error |
Synchronization was disabled due to restricted access to your mailbox. |
ExchangeConnector |
Authentication error - OAuthRefreshToken might have expired |
In order to re-enable the synchronization please go to your C4C Email configuration page and update your Exchange authorization settings and then re-enable the synchronization on the main page. |
Synchronization engine |
a limit on the number of snapshot records is exceeded (10000/10040/0) |
Number of synced records exceeded allowed limit. If the total amount of synchronized records exceeded the default 10000 records - user may receive such error message. To resolve it - user should adjust synchronization filters to reduce amount of synchronized records. |
ExchangeConnector |
Unexpected Exchange error |
The request failed. The remote server returned an error: (404) Not Found. - EWS URL - incorrect; use is not present; |
C4C Connector |
Remote server returned an error : (500) Internal server error |
Requires investigation on C4C side |
Keywords
KBA , sync issues in server side addin , number of synced records exceeded , oauthrefreshtoken , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To