Symptom
When creating a Registered Product out of an Installed Base, you notice that the field Customer is not available in the Registered Product creation screen, even though it is available when creating the same Registered Product via the Products work center.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Installed Base work center.
- Navigate to Installed Base work center view.
- Open any Installed Base.
- Navigate to Items tab.
- Click Add Item.
- Select Root-Level New Registered Product.
- In the Registered Product creation screen, notice that the field Customer is missing.
- If you try adding it via Adaptation, the field is also missing.
- Close the screens.
- Navigate to Products work center.
- Navigate to Registered Products work center view.
- Click +.
- See the field Customer is available in the Registered Product creation screen.
Cause
When the Registered Product is created out of an Installed Base, the customer of the Installed Base will be automatically copied to the Registered Product during its creation, therefore, the field is not required in the creation screen when this is made out of an Installed Base.
From the Products work center, as it is a standalone scenario, the field will be available.
Resolution
This is the standard behavior of the system.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Registered Product, RP, IBase, Installed Base, Products, Installation Point, C4C, Cloud for Customer, Customer, Field, Not Visible, Unavailable, Adaptation, Service, , KBA , LOD-CRM-SRP , Service Request Processing , Problem