Symptom
You don't know when and by whom the contact was added to the account. You assume that there should be a change log when and by whom the contact was added to account. But you can't find any change log.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customer work center
- Click on Contacts view
- Search for the contact
- Go to Business Partner work center
- Click on Business Partner Changes view
- Select Contact
- Search for the contact
Cause
The creation of the business object BusinessPartnerRelationship is not written in change documents. Reason is to avoid too many change items for the new creation of an object.
Resolution
To determine who created the object and when the object was created, you need to enable the field Created By and Created On in the Contact TI > Relationship facet.
Keywords
Business partner relationship, contact, account, no change log, , KBA , LOD-LE-BP-BP , Business Partner , Problem