SAP Knowledge Base Article - Preview

2942666 - Single Sign-On SAML 2.0 is not working in Chromium Edge with IE mode

Symptom

  • Single Sign-on with SAML 2.0 is not working in Chromium Edge browser with IE mode. It's working as expected with Internet Explorer browser.
    Accessing from Chromium Edge (IE mode), it will be looping on the IDP URL.Following errors are showing in Security Diagnostic Tool trace or Troubleshooting Wizard trace(SAP Note 1332726).
    security.saml2.sp.SAML2LoginModule Sending signed AuthnRequest to Identity Provider
    com.sap.security.saml2.sp.SAML2LoginModule OPTIONAL ok exception true Authentication Challenge due to missing credentials.
  • the error below is showing in the browser,even though have implemented the solution in SAP Note 2260036.
    Error: Service Provider could not redirect to application URL because of configuration error.


Read more...

Environment

  • SAP Netweaver ABAP Systems
  • SAP Netweaver Java Systems

Product

SAP NetWeaver Application Server for Java all versions ; SAP NetWeaver all versions

Keywords

SAML,  Chromium Edge, IE mode, Internet Explorer, Authentication Challenge due to missing credentials, Service Provider could not redirect , KBA , BC-SEC-LGN-SML , SAML 2.0 for ABAP , BC-JAS-SEC-LGN , Logon, SSO , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.