Symptom
The new button under the Follow-up items table for an existing Appointment is disabled.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activities work centre, Appointments view.
- Open the relevant Appointment.
- Go to Related Items tab.
- Under the Follow-up Items tab, the "New" button is disabled.
Cause
The appointment for which you are trying to create a follow up item is created from an unconverted Lead that was created for a Company (not linked to existing Account/Contact, the master data object have not yet been created - the lead was not created with existing account/contact/individual customer).
Since there is no actual account or contact associated to the appointment, the button "New" is disabled under the 'Follow-Up Items' tab.
The same is true for a scenario where you have an unconverted lead with a company ABC and a contact DEF (ABC represents the unconverted account, DEF the unconverted contact). While you are able to create an appointment from the unconverted lead directly, you will not be able to create a new appointment from any other screen for that same account contact:
- While the lead itself has a direct connection to the future account/ contact, this does not yet exist as master data.
- The master data only gets created with lead conversion.
- When creating appointments (or other objects for that matter) from any other screen than the lead itself, the system pulls a list of existing master data - that does not include unconverted leads.
Resolution
This is an Expected System behavior.
Keywords
new button, appointment, follow-up items, button disabled, related items , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , How To