SAP Knowledge Base Article - Public

2943602 - Filter not working due blank character - SAP SuccessFactors reportings

Symptom

  • When using “Equal to” filter and selecting a record from “Report values” tab the report is not fetching the filtered records even if there is data to be filtered.
  • When using “Like” filter and putting the same record in the text box the report is fetching the filtered records.

Environment

  • SAP SuccessFactors HXM Suite
  • Report – Canvas
  • Detailed Report
  • Advanced Report

Reproducing the Issue

  1. Use the filter in a report and select the “Equal to” operator.
  2. Then select a filter from “Report values” tab.
  3. Realize that the report will not fetch the selected values even if there is data to be filtered.

Cause

This behavior can be due to a blank space digit at the end of the record.
The Equal to operator is searching for the exactly equal record, but in the database the searched record is stored with a blank space at the end which is interpreted as a different record.

Resolution

As an Analytics solution it is suggested to create a calculated column in order to build a new column and replace it in the query. So, after identified all the records in the column with a blank space at the end, building the calculated column you need use an IF operator to replace each record with with blank space to the same record without the blank space.

2890207 - How to create a calculated column on a Canvas report?

See Also

2890207 - How to create a calculated column on a Canvas report?

Keywords

Filter; Not; Working; Report; Value; Record; Data; Base; Equal; To; Like; Replace; Calculated; Column; Blank; Space; Runtime; , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , How To

Product

SAP SuccessFactors HCM suite all versions