Symptom
The Contract Item date has expired and based on the Renewal rules configuration, you expected to have a new item created automatically right after the expiry date.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Contracts view.
- Search for the Contract ABC (ABC represents the ID of the Customer Contract).
- Navigate to the Items tab.
- You can see that Line Item 10 is expired with the Contract Item End Date 30.06.2020.
- The renewed Line Item 20 with the Contract Item Start Date 01.07.2020.
- Navigate to the Changes tab.
- You can see that the Renewal of the item was only executed on the 02.07.2020, whereas you expected to be renewed on the 01.07.2020.
Cause
Based on the configuration maintained under the Renewal and Cancellation for Customer Contracts activity, the item is expected to renewal, however, the system ran into a conflict since when the new item creation was requested, the termination for the expired item was occurring and thus blocking the document.
Also, Automatic Renewal of Contract with Auto Release has no 'renewal duration' maintained and hence when item XX was renewed, system copy the duration from previous item which was, e.g, 31 days.
If you want to renew item for 1 month duration then you should maintain renewal duration in renewal rule.
Resolution
This is the system expected behavior.
In order to avoid this in the future, please create a rule and activate the Advance Creation Duration. This will avoid the overlad of tasks being executed at the same time.
- Go to the Business Configuration work center.
- Select the Overview view.
- Search for the activity Renewal and Cancellation for Customer Contracts.
- Create a new rule.
- On Renewal Create: Contract.
- Enter a value for Advance Creation Duration, for example: 2 Hour(s).
Keywords
Contract, Renewal, Item, Expired, Advanced Creation Duration, Customer , KBA , csg_q , AP-CCP-CC , Customer Contract , How To