SAP Knowledge Base Article - Public

2944990 - IAS Upgrade error when validating S-User credentials

Symptom

  • Receiving "Invalid S-User. Enter the correct S-User for this company" error message when entering S-user credentials for IAS upgrade
  • Unable to complete "Initiate SuccessFactors SAP Cloud Platform Identity Authentication Service Integration" due to error with S-user
  • Receiving "Invalid username/password" error message when entering S-user credentials for IAS upgrade
  • When attempting to carry out the first IAS related upgrade in Upgrade Center, the below warning is experienced by customer: "We are unable to validate your customer credentials at this time and proceed with the Upgrade to SAP Cloud Identity Authentication Service. Please contact support to report the issue."
  • Error of invalid S-user for a valid S-User, however it is associated with the ERP Customer ID and not with the CRM Customer ID

Environment

  • SAP SuccessFactors HXM Suite
  • SAP Cloud Platform Identity Authentication Service

Reproducing the Issue

  1. Navigate to Upgrade Center
  2. Select "Initiate SuccessFactors Identity Authentication Service Integration"
  3. Pop-up window will appear asking for S-user credentials > enter S-User credentials
  4. Click on "Validate"
  5. Any of the below errors appear:
    • Invalid S-User. Enter the correct S-User for this company
    • Invalid username/password
    • We are unable to validate your customer credentials at this time

Cause

  1. Error "Invalid S-User. Enter the correct S-User for this company" appears if the S-user ID being entered is not tied to the ERP customer number that the BizX system belongs to.
  2. Error "We are unable to validate your customer credentials at this time and proceed with the Upgrade to SAP Cloud Identity Authentication Service. Please contact support to report the issue" is related to a validation recently implemented in SuccessFactors. It's expected for it to be shown when the respective database table — crm_customer_id — don't have the Customer CRM ID information populated.
  3. Error "Invalid username/password" indicates incorrect credentials.

Resolution

Please find below how to address the issues related to your S-user ID depending on the error being received.

Invalid S-User. Enter the correct S-User for this company

Make sure you S-user is linked to the customer number that owns the system you are performing the Upgrade. Additionally, use S-user associated with the CRM customer ID. In case of non exists or has only associated to ERP Customer ID, request a new S-User to be created and associated with the CRM customer ID.

Sometimes, the account is is tied to a Corporate Group Function (CCC) and the user will end up being able to execute functions (for example, report an case , request SSCR keys, and so on) only for the ERP customer number they were assigned to.

To learn more about Corporate Group (CCC) function, check the below KBA:

2632518 - Information about the SAP Corporate Group (CCC) function

Please note that the SAP Customer Contact/CSP can help informing the S-user that has the administrator role to run the upgrade.

Note for Support-> Please check the internal memo section of the KBA on identifying this scenario from application logs. 

S-user has Universal ID

If your S-user has Universal ID, a potential cause is that the Universal ID password for that S-user ID being used is actually different from SAP IDS password. Therefore, our recommendation would be for the below steps to be followed:

  1. Go to https://accounts.sap.com/
  2. If it requests you to change the password, change it, log out and login of the instance, and try to trigger the upgrade again with the new password
  3. If not: Enter the S-User Id and Password in that page, and login. If the login works, try the exact same Id and Password in the IAS upgrade and then update us.
  4. If the login does not work, use the Forgot Password option to trigger a password reset email, reset password, go back to https://accounts.sap.com and again try the login with the S-user id and new password
  5. if the login works, try the exact same Id and Password in the upgrade and then update us

Universal ID is for "accounts.sap.com" login itself, but the password management might be different internally, leading to the issues with the upgrade. Please proceed with the above and let us know the outcome.

Invalid username/password

    • Make sure the password being entered is the correct one. In case the password is not being accepted, test to reset the password, as per the below KBA:
      1808560 - How to reset an S-user ID password - SAP for Me 
    • important: If your SAP IDS account has Two-Factors Authentication (TFA) enabled then in that password has to be concatenated the IDS password and the current TFA code.
      For example, if the password is “Welc@me1” and the generated valid TFA code is “987345” – he should provide as a password in SF Upgrade form: “Welc@me1987345
    • If both the above are correct, and still the error appears while running the upgrades, please submit a support ticket to LOD-SF-PLT-IAS component including a Network Trace for the validation error replication scenario. KBA on how to capture a network trace-> 2760505

This upgrade process does not work for Sales Demos at present. Paid Sales Demos are created with pre-integrated IAS & IPS

Notes for Support: Please check the Internal Memo section of the KBA for troubleshooting guidance.

Then if all above is good, file an case with IAS Team through the component LOD-SF-PLT-IAS and assignment group SF-PLT Foundations-PLT-Product.

Within the case description, provide the Company ID and IAS Instance URL.

See Also

  • KBA 2843423 - IAS via Upgrade Center | No tenants created nor credentials email received after running the "Create/Initiate [...]" task
  • KBA 2791410 - Integrating SuccessFactors with SAP Cloud Identity Authentication Through the Upgrade Center

Keywords

S-user error, upgrade IAS error, IAS initiate issues, upgrade, upgrade center, s user, validation, validate, patch, IAS initiate error, We are unable to validate your customer credentials at this time and proceed with the Upgrade to SAP Cloud Identity Authentication Service. Please contact support to report the issue, Invalid S-User. Enter the correct S-User for this company , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , How To

Product

SAP SuccessFactors HXM Suite 2205

Attachments

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