Symptom
Language Adaptation with Source text appearing as "<No Text Found>"
Environment
- SAP Cloud for Customer
- SAP Cloud Application Studio
Reproducing the Issue
Pre-requisite: You have created 2 language adaptations, called "German" and "French". In other words translating from English to German and then German to French.
You have created a PDI Field, for which you are now trying to maintain the translation.
- Administrator
- General settings
- Language Adaptations
- Open "German"
- Search for translated field "Lead"
- Translation maintained. Source and Target Text are available
- Open "French"
- Search for the same field as above
- Source Text will appear as <No Text Found>
The translation from Source Text English to Target Text German will work without issues, however trying to translate the same text from Source Text German to Target Text French will result in the "<No Text Found>"
Cause
The Language Adaptation reads the source texts as originally delivered by SAP or as deployed by PDI.
In case of PDI: if texts are developed in English they will only be found in English, irrespective of whether they have been translated in other languages using the Language Adaptation. In other words, going from English to German and then German to French, will not work as the Language Adaptation never reads its own translations/adaptations.
Resolution
As described above, this behavior/requirement is simply not yet implemented.
To resolve this issue one must always translate from Source Text English or alternatively translate texts fields in the Cloud Application Studio using .XLIFF file.
See Also
[Enter your See Also here...]
Keywords
"<No Text Found>", Language Adaptation, Text, Textpool, Source Text, PDI , KBA , AP-RC-TXA , C4C Text Adaptation , Problem