Symptom
When uploading Service Request Attachments via Data Workbench work center, the custom type is not being set correctly. It defaults to the standard attachment, even though the custom types for service requests have been defined in the fine tuning activity Customer-defined document types for attachments.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Data Workbench work center
- Click on Import view
- Click on Attachment
- Select Standard Object
- Search for Service Request Attachments
- Click on Next
- Upload file
- Click on Next
- Click on Import
- Go to Service work center
- Click on Tickets view
- Search for relevant ticket
- Go to Attachment tab
- Note: The type is standard attachment.
Cause
In the UI, when opening a ticket > Attachment tab > Add > Web Link, then Link and Title are the only two options. The type of attachment cannot be changed.
Resolution
Data Workbench defaults the attachment type to standard attachment for Web Link. This is the standard system behaviour.
See Also
service request attachments, custom type not being set properly, activity Customer-defined document types for attachments, defaults to standard attachment,
Keywords
KBA , LOD-CRM-INT-DWB , Data Workbench , LOD-CRM-SRP , Service Request Processing , Problem