SAP Knowledge Base Article - Public

2945815 - Custom Type for Attachment Defaults to Standard Attachment When Importing Service Request Attachments in Data Workbench Work Center

Symptom

When uploading Service Request Attachments via Data Workbench work center, the custom type is not being set correctly. It defaults to the standard attachment, even though the custom types for service requests have been defined in the fine tuning activity Customer-defined document types for attachments.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench work center
  2. Click on Import view
  3. Click on Attachment
  4. Select Standard Object
  5. Search for Service Request Attachments
  6. Click on Next
  7. Upload file
  8. Click on Next
  9. Click on Import
  10. Go to Service work center
  11. Click on Tickets view
  12. Search for relevant ticket
  13. Go to Attachment tab
  14. Note: The type is standard attachment.

Cause

In the UI, when opening a ticket > Attachment tab > Add > Web Link, then Link and Title are the only two options. The type of attachment cannot be changed.

Resolution

Data Workbench defaults the attachment type to standard attachment for Web Link. This is the standard system behaviour.

See Also

service request attachments, custom type not being set properly, activity Customer-defined document types for attachments, defaults to standard attachment,

Keywords

KBA , LOD-CRM-INT-DWB , Data Workbench , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions