Symptom
When you execute Odata Service for Customer Incident either in Browser or in Odata Console, system throws below error
Not authorized; check authorization restriction for the user
Environment
SAP Business ByDesign
Reproducing the Issue
Enter the Odata Collection endpoint for Customer Incidents in browser
https://myXYZ.sapbydesign.com/sap/byd/odata/v1/customerincident/$metadata
Cause
Necessary Scoping Questions are not scoped in the system
Resolution
The OData service- customer incidents is used to access the Partner support request BO.
To use this service, the system must be partner enabled. Configure partner system: https://blogs.sap.com/2017/06/20/how-to-configure-and-use-the-new-feature-of-byd1705-customer-incident-handling-by-partner/
The authorization to the user is provides as work center assignment. Please assign the work center /ITSAM/CUST_INCIDENT( Customer Incidents ) to the user.
After setting up the system, the odata service-customer incident can be used.
Keywords
Customer incident, Partner support , KBA , AP-RC-ODF-BYD , OData Framework and Console (ByD) , Problem