SAP Knowledge Base Article - Public

2946911 - Missing Warranty ID When Creating Custom OData Service For the Business Object: Warranty

Symptom

You notice that WarrantyID is missing in the ROOT when creating custom OData service for the business object: Warranty.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Application and User Management work center
  2. Select the OData Services view
  3. Under Overview, select Custom OData Services
  4. Select the New button
  5. Fill the Service Name field with value, e.g. 'Warranty', 'Test' etc.
  6. Save and Open to continue
  7. Click  Select Business Object
  8. BO Name Warranty and BO Node Name: Root
  9. Expand the Root

You notice that there is no property name called Warranty ID, instead you will only see ProductIntenralID.

Cause

The ProductInternalID on the Root Node of business object Warranty is the Warranty ID itself.

Resolution

There is no field called Warranty ID on the business object. ProductInternalID represents the WarrentyID.

Keywords

Root, ProductIntenralID , KBA , AP-PRD-WAR , Warranty , How To

Product

SAP Business ByDesign all versions