SAP Knowledge Base Article - Public

2947494 - Field Missing in Payment File When Using Customized Payment File Format

Symptom

After creating a customized Payment File Format the Customer ID at Supplier field is missing in a newly created outbound file.

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to the Liquidity Management work center.
  2. Go to the Outbound Files view.
  3. Show All Outbound Files.
  4. Select the respective file ID.
  5. Press View All.
  6. Go to the Attachment tab.
  7. Download the file.

The Customer ID at Supplier field is missing in the file.

Cause

The new payment file format is assigned to the  SAP delivered Payment Medium Format 36 - UK BACS Domestic Payment. Due to this standard Payment Medium Format's special coding some of the more generic code, such as the Customer ID at Supplier field, might get skipped, as this information is not usually required for this particular payment medium format.

Resolution

Create a new customized Payment Medium Format and assign this new format to the customized Payment File Format. This way the Customer ID at Supplier field will be correctly derived in the generated Payment Files.

Keywords

Payment File; Payment File Format; Customer ID at Supplier; Payment Medium Format , KBA , payment file , payment file format , customer id at supplier , payment medium format , AP-PAY-GLO , Cross-Country Extensions , How To

Product

SAP Business ByDesign all versions