Symptom
Time Off Tab Section on some users profile is showing as blank, although affected user does have open active time accounts in Manage Data UI.
This is affecting Entitlement Time Account users where simulation is active.
Environment
Employee Central, Time Off
Reproducing the Issue
1. Navigate to affected users Profile as an admin > Time Off Tab
2. You can see this is blank with no time data / administer time link
3. Navigate to Take Action > Manage Leave of Absence > Time Accounts Tab > No data exists
4. Check in Manage Data UI if you have added User ID as a searchable field on the Time account object in Configure Object Definition
5. Search Time account > User Id > Time accounts appear
Cause
User has an entitlement time account where system is trying to set an invalid next transfer date, due to misconfigured Accrual Transfer Date Rule
Resolution
Please create a support case if you need assistance identifying the time account type which is using entitlement method as mentioned:
Check the users time account which is of type Accrued as entitled > Accrual Transfer date rule > Are you setting the date based on an empty / non existent field?
Please correct the rule, rerun the entitlement calendars and test navigating to the users profile again.
If simulation is disabled on the time account type the issue will not occur, but rule should be corrected.
Engineering are working on how the UI will handle this misconfiguration issue, which will be updated in this KBA once confirmed.
Keywords
of a null object loaded from local variable 'entitlementPeriod', EntitlementRuleDataRecordFactory, Time off tab empty, Time Off UI blank, Time off section shows no data, fingerprint=31118953f5ea2faff19900c528b918cd0b9e1246, TIM-14741 , KBA , LOD-SF-EC-TIM , Time Off , Problem