SAP Knowledge Base Article - Public

2948257 - KUT Rule and Validation cannot be Applied

Symptom

You want to apply KUT rule / validation in Activities facet but rule option is not shown.

Reproducing the Issue

  1. Go to Customer work center.
  2. Go to Accounts view.
  3. Open any Account and navigate to Activties facet.
  4. Start Adaptation mode.
  5. There is no option to apply rule to either button such as New or Appointment, Tasks or Phone Calls Pane.

Cause

This is expected behaviour. Rules and Validations cannot be applied in embedded component. Since Appointment, Tasks , Phone Calls or E-mails are embedded component, this will not work

Keywords

KUT rule, KUT validation, Model rule, Activities facet, Rule in EC, rule in embedded component, Rule option not shown, EC limitation, Rule limitation , KBA , rule in ec , kut validation , rule limitation , ec limitation , activities facet , rule in embedded component , kut rule , model rule , rule option not shown , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions