Symptom
You want to apply KUT rule / validation in Activities facet but rule option is not shown.
Reproducing the Issue
- Go to Customer work center.
- Go to Accounts view.
- Open any Account and navigate to Activties facet.
- Start Adaptation mode.
- There is no option to apply rule to either button such as New or Appointment, Tasks or Phone Calls Pane.
Cause
This is expected behaviour. Rules and Validations cannot be applied in embedded component. Since Appointment, Tasks , Phone Calls or E-mails are embedded component, this will not work
Keywords
KUT rule, KUT validation, Model rule, Activities facet, Rule in EC, rule in embedded component, Rule option not shown, EC limitation, Rule limitation , KBA , rule in embedded component , kut rule , activities facet , model rule , ec limitation , kut validation , rule in ec , rule option not shown , rule limitation , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , Problem