Symptom
You have upserted a User record via OData API or Employee Import to change its status from true to false (active to inactive) or false to true (inactive to active) and the status change was not effective.
Environment
- SAP SuccessFactors HXM Suite
- OData API
Cause
The upsert may have been done while an HRIS Sync job was executing in the background. Here's an example scenario which explains the behavior:
- HRIS SYNC job starts and reads the current data of employee (status is INACTIVE, for example)
- EC side changes are merged, and since there's no status change in EC, the job acknowledges that the user status remains INACTIVE. This information is stored to be applied later;
- Meanwhile, the OData upsert is made directly to the User entity to switch the status to ACTIVE;
- HRIS Synch finishes after the upsert and the information stored in step 2 is applied, so user status is reverted to INACTIVE.
For more information on the HRIS Sync, please refer to:
Resolution
This is the current expected behavior. Please ensure you are not upserting User informatiom while an HRIS sync is running. If you need further assistance related to HRIS Sync, please open a ticket under the LOD-SF-EC-HRS component.
Keywords
synch, upsert, update, status, change, changing, modification, modified, t, f, user, employee, import , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , LOD-SF-EC-HRS , HRIS Sync , Problem