SAP Knowledge Base Article - Public

2949530 - "Stop Accrual at Upper Balance Limit" is not Working

Symptom

You have configured Time Account in such a way that the system shoud accept a maximum of X hours as Accural. You have set up Upper Balance Limit as X and "Stop Accrual at Upper Balance Limit" is checked

But In the Time File of the employee, it is possible add more than X hours (either through Manual Adjustment or Transfer)

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Business Configuration work center
  2. Open the Fine tuning activity Time Accounts
  3. Highlight Time Account Type
  4. Go to Accural Rule sub tab
  5. Posting Type - Entitlement; checked the check box "Stop Accrual at Upper Balance Limit"; Upper Balance Limit = X

Cause

There is no way to limit an account to X hours. The accrual rule only stops the periodic accrual.

An example would be the following:

An employee gets 16 hours Paid leave every month up to a certain limit. Once this limit is reached, the system will not automatically add any hours to the time account anymore. If the limit would be 30 hours i.e. the system would add 16 hours to the time account in the first month and 14 hours in the second month.

Afterwards it would stop awarding time until the employee is taking time out of the account by booking a leave.

Resolution

Manual adjustments and transfers can still be done as the accrual rule only limits the accrual that is set up and not any external factors.

Keywords

Stop Accrual at Upper Balance Limit, Upper Balance Limit, Accural , KBA , SRD-HR-TLM , Time and Labour Management , Problem

Product

SAP Business ByDesign all versions