Symptom
"Reason for Rejection" field is not editable in Sales Order / Sales Quote unless there is a Product.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Sales Orders / Sales Quotes work center view.
- Open the Sales Order ABC (ABC represents the Sales Order ID)
- Click the Edit icon.
- Edit the "Reason for Rejection" field.
Result: The field is greyed out and unable to put a reason.
Cause
The "Reason for Rejection" field is reflected at both header and item level, which means the Sales Order or Quote is cancelled in both header and item level. As there is no product in the sales document the rejection is not meaningful. However, this can be made available by enabling a scoping question in the Business Configuration.
Resolution
- Go to the Business Configurations work center.
- Go to the Implementation Projects work center view.
- Select the project.
- Click Edit Project Scope.
- Click Next till 4 Questions.
- Click Sales.
- Click New Business.
- Click Sales Quote.
- Scope the question "Do you want to submit sales quotes without items?".
- Save the change.
Please note this solution works for inbound replication only.
For bi-directional sales documents the field reason for rejection is not editable, since in ERP the cancellation is possible only on item level and hence header cancellation cannot be transferred to ERP and mismatch should be avoided. This is the expected behavior.
See Also
Keywords
Bidirectional, ERP, ECC, rejected, set to lost , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , Problem