SAP Knowledge Base Article - Public

2950684 - 'Reason for Rejection' Field is Not Editable in a Sales Order/Quote

Symptom

"Reason for Rejection" field is not editable in Sales Order / Sales Quote unless there is Product

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center
  2. Go to the Sales Orders / Sales Quotes work center view
  3. Open the Sales Order ABC (ABC represents the Sales Order ID)
  4. Click the Edit icon
  5. Edit the "Reason for Rejection" field

Result: The field is greyed out and unable to put a reason.

Cause

The "Reason for Rejection" field is reflected at both header and item level, which means the Sales Order / Sales Quote is cancelled in both header and item level. As there is no product in the Sales Order / Sales Quote, rejection is not meaningful, however you can make this available by enabling a scoping question in the Business Configuration.

Resolution

Enabling a scoping question "Do you want to submit sales quotes without items?".

  1. Go to the Business Configurations work center
  2. Go to the Implementation Projects work center view
  3. Select the project
  4. Click Edit Project Scope
  5. Click Next till 4 Questions
  6. Click Sales
  7. Click New Business
  8. Click Sales Quote
  9. Scope the question "Do you want to submit sales quotes without items?"
  10. Save the change.

See Also

2507825 - Cancelled Sales Orders are showing wrong status

2540377 - FAQ for Sales Quotes

2890898 - Error Changing Reason for Rejection not possible; field is read-only While Updating Sales Orders Using Data Workbench

Keywords

Reason for Rejection, Order, Quote, Do you want to submit sales quotes without items , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer core applications all versions