Symptom
"Reason for Rejection" field is not editable in Sales Order / Sales Quote unless there is Product
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center
- Go to the Sales Orders / Sales Quotes work center view
- Open the Sales Order ABC (ABC represents the Sales Order ID)
- Click the Edit icon
- Edit the "Reason for Rejection" field
Result: The field is greyed out and unable to put a reason.
Cause
The "Reason for Rejection" field is reflected at both header and item level, which means the Sales Order / Sales Quote is cancelled in both header and item level. As there is no product in the Sales Order / Sales Quote, rejection is not meaningful, however you can make this available by enabling a scoping question in the Business Configuration.
Resolution
Enabling a scoping question "Do you want to submit sales quotes without items?".
- Go to the Business Configurations work center
- Go to the Implementation Projects work center view
- Select the project
- Click Edit Project Scope
- Click Next till 4 Questions
- Click Sales
- Click New Business
- Click Sales Quote
- Scope the question "Do you want to submit sales quotes without items?"
- Save the change.
See Also
Keywords
Reason for Rejection, Order, Quote, Do you want to submit sales quotes without items , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , How To