Symptom
Following the creation of a rewards program you are attempting to either download current guidelines file or import a new file.
Through these processes you are receiving a "System error" popup.
Why is this and how can this be corrected?
**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**
Environment
SAP SuccessFactors Rewards & Recognition
Reproducing the Issue
[Enter your Reproducing the Issue here...]
Cause
Through debugging you can see the following error from either action.
Exporting file - Network tab
Response text
{
"error" : {
"code" : "ServerErrorException", "message" : {
"lang" : "en-US", "value" : "while trying to invoke the method com.sf.sfv4.bean.succession.SuccessionDataModelBean$StandardElement.getPicklistId() of a null object loaded from local variable 'smElementCountry'"
}
}
}
Importing file - Network tab
Sample server logs
09:43:01,890 ERROR [OData4jExceptionMappingProvider] [193.16.224.9] [1973127] [de1d65913961b9c6955a084d01ee7c57] [TEST ,COMPANY SA,dc5prd_TESTCOMPANY.,dbPool4,8858144EE8E6B8,8858144EE8E6B8,42807,en_GB] [E4AC5B7EEC] [][]ExceptionRootCauseTag=c5ec9ae8e1210a665d79f262f76b48475d33f761,ExceptionStackTraceTag=09b4511d4de52cca223f49b5a0a8431efdd5534e TotalStackTree: java.lang.NullPointerException: while trying to invoke the method com.sf.sfv4.bean.succession.SuccessionDataModelBean$StandardElement.getPicklistId() of a null object loaded from local variable 'smElementCountry' at com.successfactors.spotawards.util.SpotAwardsServiceUtil.getCountryPickListBean(SpotAwardsServiceUtil.java:1533) at com.successfactors.spotawards.util.SpotAwardsServiceUtil.getContryPickListBean(SpotAwardsServiceUtil.java:1573) at com.successfactors.spotawards.util.SpotAwardsCountryUtil.loadCountryPickListBean(SpotAwardsCountryUtil.java:57) at
com.successfactors.spotawards.util.SpotAwardsCountryUtil.<init>(SpotAwardsCountryUtil.java:40) at
Resolution
From the logs and debugging we can see we are trying to get country information from the succession data model.
If this standard element is not present in your instance this error will populate.
To check this, please go to "Company Settings> Manage Business Configuration> Employee Profile> Standard" and ensure you have "country" enabled.
Once this is Enabled=Yes save, exit and try uploading/exporting guidelines which should be successful with no errors.
Keywords
guidelines system error, unable to export guidelines, rewards & recognition system error, system error, import guidelines error, smElementCountry, , KBA , LOD-SF-RNR-GDL , Guidelines, Categories, Levels etc. , LOD-SF-RNR , Reward and Recognition , LOD-SF-RNR-ADM , Admin Tools, Program Setup & Object Permissions , Problem