Symptom
A new contract for selling entitlement products is created and released, however when creating the service confirmation to confirm the execution of the entitlement no products are available for selection in the Services and Spare Parts tab.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Contracts View.
- Filter for All Contracts.
- Search for the Contract ABC. (ABC represents the ID of a Contract)
- Open, Select View All.
- Navigate to the Items tab.
- Mark the Line Item XX. (Where XX represent the Line Item Number of the Entitlement Product)
- Go to Entitled Products sub tab. (The service product is maintained)
- Click Submit - Confirm Execution button.
- In the New Service Confirmation screen, Click Add Row button in the Services and Spare Parts section.
- In the Product ID field, Select the value help.
There is no item proposed displayed in the Service Confirmation.
Cause
There is no item proposed displayed in the Service Confirmation due to the Item Type of the contract item. In this case, the item type of contract Line Item is Entitlement - fixed price w/o actuals. It is not a confirmation relevant item type for entitlement, hence no confirmation is required.
Resolution
This is the current system behavior.
Keywords
Entitlement, Product, Services, Contract, Service Confirmation , KBA , SRD-CRM-ORD , Orders & Contracts , SRD-CRM-SEO , Service Orders , How To
SAP Knowledge Base Article - Public