SAP Knowledge Base Article - Public

2951872 - WFA High Chart cannot be exported due to "Unable to connect to the High Charts server error

Symptom

  • When exporting a WFA or Canvas page with High Chart component, the resulting file shows the following error for the High Chart:
    '[Unable to connect to the High Charts server. Please contact SuccessFactors.]

  • Report Online Preview displays the High Chart correctly.

Environment

SAP SuccessFactors Workforce Analytics

Reproducing the Issue

  1. Run the report
  2. The page will be displayed and will render all chart and table data correctly during Online
  3. Export the page or the component
  4. The page will be exported successfully however The High Chart won't render and the error '[Unable to connect to the High Charts server. Please contact SuccessFactors.]' will displayed

Cause

Special character was added to the component name.

Resolution

Special characters to the component name is not supported in Canvas report. Please edit the component and remove any special characters.

Keywords

High Charts, server, phantomjs, high charts service, chart not rendering, export  , KBA , LOD-SF-WFA-WA , Workforce Anaytics , Problem

Product

SAP SuccessFactors HCM Core all versions