SAP Knowledge Base Article - Public

2952799 - The URL resolved by token is not a clickable link in some mail clients - Recruiting Management

Symptom

The URL resolved by token is not a clickable link in some mail clients.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Cause

It depends on how the mail client renders links in the email body.

Resolution

It is advisable to use the link button to add the token as a hyperlink.

Please refer to the screenshots below:

1. Click on the Link button to add the token to hyperlink.

2. Enter the token in URL. Select <other> for Protocol.

If you are still facing issues even after doing these steps, please try the following:

  1. Admin Center>Manage Recruiting Email Templates>Select email template
  2. Copy the body of the email template and then paste it into Notepad
  3. Copy the body of the email template from Notepad back into the email template in the instance
  4. Set up Hyperlink settings again as per screenshot above
  5. Admin Center>Recruiting Email Triggers>Select email trigger
  6. Disable trigger and then re-enable it
  7. From the "Email Template" drop-down, choose a different template and then re-choose the desired email template.
  8. Click Save
  9. Admin Center>OData API Metadata refresh & Export>Refresh
  10. Log out then log back in
  11. Trigger email again and token should resolve

Keywords

mail client, URL, hyperlink, token, email template , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions

Attachments

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