SAP Knowledge Base Article - Public

2953616 - Mobile App Password Complexity Is Not Working

Symptom

Mobile App Password Complexity (passcode policy) is not respected in C4C.

Environment

SAP Cloud for Customer Extended Edition Mobile App

Reproducing the Issue

  • Go to Administration.
  • Go to Business Users->Edit Attributes.
  • Go to Mobile App Logon Password section.
  • Change the Mobile App Password Complexity eg:change number of characters to 4.
  • Save and Close the changes.
  • Open any Extended Edition app.
  • Passcode will still ask for 8 character PIN with the below error message:

Cause

This is a standard behaviour. Passcode value should have 8 characters with the above criteria.

Resolution

This is a standard behaviour. We will be removing the option to change Mobile App Password Complexity in the future releases.

See Also

2377118 - Passcode Policy is Ignored if Multiple Logon is Enabled in Hybris C4C Extended Edition App

Keywords

Passcode,Mobile App Password Complexity,App Logon,Business Users,Security Policy , KBA , passcode , mobile app password complexity , app logon , business users , security policy , AP-RC-MOB-AND , SAP Hybris Cloud for Customer Extnd App on Android , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions