Symptom
How to modify Question's Rating Scale when the drop down menu is not available to change it?
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning
Reproducing the Issue
Going to the Survey > Questions Admins are not able to edit the Rating Scale.
The drop down menu is not available to select a different Rating Scale option.
Cause
According to Product Management team this is an expected behavior from the system.
When a Survey is already accessed by an User, the Question's type is no longer editable by the Admin.
Resolution
If it is desired to change the Rating Scale from the Question, please follow the below steps to proceed:
Go to Content > Survey > Summary > Click on Copy button
A new Survey will be created, please set the Survey ID and go to Questions > Create Draft > It will be possible to select the Rating Scale > Publish
After publishing it, go to the Item, remove the previous Survey associated with the Item and add the new one.
Please note: The previous Survey related to the Item will still be available on the relevant Reports to check the answers. Please select the option: Include Previous Item Associations: Yes, at the Report's filter.
Keywords
Rating Scales, Survey, Questions, Edit Rating Scales, INC0069489 , KBA , LOD-SF-LMS-ASB , Assessment Builder , How To