Symptom
When creating candidate accounts via Bulk Create Candidates from .CSV File, all the records failed, even if all the information provided was correct.
"Failed records count : x".
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Import new candidate data via Bulk Candidate Import (2779621)
- Go to Scheduled Job Manager
- Check the job. The job name will always starts with "RCM_CandidateByCSVUploadJob"
- All the records inside the job failed.
Cause
There are two possible misconfiguration that will cause the Candidate Profile record to fail. Please refer to the Resolution section.
The system will not create the new profiles if country field is not configured as expected. For example, the picklist is not the default picklist.
Resolution
Cause 1: The Country field is not configured as expected.
The country field must be configured as explain the in the following KBA, otherwise it will jeopardize the candidate import, among other features.
2220688 - Candidate Country field behavior and Known Issues - Recruiting Management
One way to confirm this issue is checking if all the values being provided in the file are correct but when looking into the logs, the same values appear as incorrect.
The logs show the following information even if the value is correct in the picklist: "Incorrect values: [Value Texas of field state is invalid for picklist state.]".
Since the country field was not configured correctly, the system was not able to address the child state value to the parent country value, resulting to the error.
Cause 2: There are two or more Country values representing the same Country.
It may happen in Preview or QA environment that a Country is configured two or more times on the Country picklist.
This can cause the parent-child relationship to brake, since you can refer a child value to the wrong parent value. For example, you have two Mexico values on your picklist configuration and both have the same label "Mexico". One Mexico value has all the parent-child picklist relationship and the other doesn't have it. So, when referring to Mexico value and addressing a child value, probably State field, the system will not recognize which of both values you are referring to, so it may occur that the second Mexico value, which doesn't have any child, is selected, therefore since you referred a child value to a parent value which has no relationship, the record import will not work.
Duplicated values on the Country picklist is a missing configuration. Please make sure to have only one value per Country.
Cause 3: There are cascading fields and value populated in the child field is invalid/null.
For cascading picklist, when you update the value of the parent, you should also provide the value for the child. Also be sure that proper parent and child mapping is set in the field in template level and in picklist values.
See Also
2807356 - Bulk Creation of Candidates with CSV file is failing - Recruiting Management
2808373 - Error Message When Downloading the Blank .CSV Template File - Recruiting Management
2220688 - Candidate Country field behavior and Known Issues - Recruiting Management
Keywords
Bulk, Failed, Candidate, Import, CSV, Issue, Profile, Record, Fail , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem