Symptom
You have created a page layout for UI changes in the Service Templates Work Center View. However, the changes are not being applied.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service Work Center.
- Go to Templates View
- Start Adaptation.
- Select desired Page Layout ABC (Where ABC is the page layout for this screen).
- Perform the UI changes.
- Assign the Page Layout ABC to desired Business Role 123 (Where 123 is the business role for the users which should see this changes for this page layout).
- When logging with and user from business role 123 the changes are not applied.
Cause
The most common issue for this case is the wrong business object (BO) selected when assigning the page layout. The Templates view are not part of Tickets BO. The correct Business Object for this screen is Formatted Template.
Resolution
You should assign the Page Layout ABC for Business Role 123 under Business Object Formatted Template.
- Start Adaptation.
- Go to Layouts tab.
- Click at Assign Layouts.
- In the assigning screen select Formatted Template at business object field.
- Change the layout field from Master Layout to Page Layout ABC at line Business Role 123.
- Save.
- Leave Adaptation.
Keywords
Page Layout Templates, Templates view, Ticket Templates, Formatted Template , KBA , AP-RC-UIF , C4C UI Framework , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2008