Symptom
You try to submit your UK VAT return to the HMRC.
The Submission gets returned with the error "Technical Response: : error : invalid_grant,error_description : replace_access_token HTTP code: 400|Refresh access failed, please reset the access grant for account".
Environment
SAP Business ByDesign
Reproducing the Issue
- In the Tax Management work center go to the VAT Returns view.
- Find and select VAT return XXX, in Status Reported (The VAT return has been released and returned and is ready to be submitted to the HMRC) (XXX represents the VAT return ID).
- Press View to open the return.
- In the new screen press Submit.
- The Submission is not successful: In the Submission Information section the following information appears:
- Submission Status: Returned
- Approval Status: Rejected
- Error Description: |Technical Response: : error : invalid_grant,error_description : replace_access_token HTTP code: 400|Refresh access failed, please reset the access grant for account.
Cause
If there are any account changes like Add/Remove of the Authorized Account performed by user, then the grant access gets expired automatically from the external website. In this case, user has to generate the new code from the external site.
Resolution
To generate the new Code to grant the access follow the below steps:
- Login to the system with an authorized Business User.
- Go to the Business Configuration work center.
- Access the Fine Tune activity UK Making Tax Digital.
- Here, the user can see Authorized Account.
- Press Allow Access.
- You will be re-directed to the external website to grant the new code.
- Once the new code is generated from the external website you can submit the VAT Return.
Keywords
please reset the access grant for account, UK MTD Error, UK Making Tax Digital, Refresh access failed , KBA , uk making tax digital , uk mtd error , please reset the access grant for accoun , refresh access failed , SRD-FIN-GLO-TAX , GLO - Tax Declaration , Known Error