Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
In app Manage G/L Account Master Data, navigation to the detail object page was triggered via the link in the column “G/L Acct External ID” or "Company Code". However, they are not available anymore since the release 2008.
Environment
SAP S/4HANA Cloud Public Edition 2008 or above
Reproducing the Issue
- Open app Manage G/L Account Master Data, select chart of account: YCOA, and click Go.
- You can't click the G/L account number to see details(no smart link anymore), but you need to click details navigation in smart table column.
- Scroll Mouse wheel down to bring the screen to desired location: company code data, then you will find you can't click the company code to see details(no smart link anymore), but you need to click details navigation in smart table column.
Cause
It's a new navigation change to keep UX consistency when using different Fiori apps in S/4HANA.
For internal navigation, the standard navigation column to the detail page is provided, instead a navigation is triggered either via links in table columns or via toolbar buttons. For external navigation, always Smart Link is offered(exceptional cases excluded).
In this case, for the app Manage G/L account master data, we would see:
Before the release 2008: Navigation to the Object Page is triggered via the link in the column “G/L Acct External ID” or "Company Code".
After the release 2008: Use the standard navigation column to the detail page in Smart Table.
Resolution
It is a standard behaviour in the release 2008 to keep UX consistencies in Fiori Apps in S/4HANA.
Keywords
Manage G/L Account Master Data, Navigation, release 2008, UX consistencies, Inconsistencies, G/L Acct External ID, Company Code, Smart Link, link, column , KBA , FI-FIO-GL-MD , Master Data Apps , FI-FIO-GL-MD-2CL , Master Data Apps (Public Cloud) , Product Enhancement