Symptom
The following error is thrown when trying to approve a Benefit Enrollment Workflow: ???BENEFITS_INVALID_PREVIOUS_ENROLLMENT_ID???
Environment
Employee Central - Global Benefits
Reproducing the Issue
1. Open Benefit Enrollment Workflow
2. Click Approve
3. Error: ???BENEFITS_INVALID_PREVIOUS_ENROLLMENT_ID???
Cause
This is a known problem with Insurance type enrollments.
Resolution
This issue was fixed in 2H 2020. However, if you're still facing the issue, please the following work-aroind:
Workaround:
1. Open the enrollment on the workflow that is throwing the error
2. Note the Benefit Name and Insurance Plan from the enrollment
3. Now open the Benefit from Benefits Admin Overview or Manage Data
4. On the Benefit configuration move the Insurance Plan you noted previously to be the first entry in the list of Insurance Plans included on the Benefit
5. Save
6. Now you will be able to approve Workflow
Keywords
???BENEFITS_INVALID_PREVIOUS_ENROLLMENT_ID???, Benefit, Benefites, Invalid, Previous, Enrollment, Enrolment, ID, Workflow, Approval, Error, Insurance, Plan, BEN-5788, INC0058288, INC0075925, , KBA , LOD-SF-EC-GBF , Global Benefits , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem