Symptom
App "Schedule Billing Document Request Creation" shows status "Error" and Log Details shows the detailed error description.
The contract gets the status "Contains Errors" in the “Manage Service Contracts” app, with the error message "Customer XXX: Customer master table KNVV is missing" in the detail page of the contract.
Environment
S/4HANA Service Cloud
Reproducing the Issue
- Create a Service Contract.
- Enter a Sales Organization, Distribution Channel and Division.
- Enter a Customer in the Sold-To Party whose master data was not created in the previous organizational data.
- Release and Save the Service Contract.
- Schedule the BDR creation in the "Schedule Billing Document Request Creation" app.
- Check the Log of the job.
Cause
Customer master data was not created for the Sales Organizational Data of the Service Contract and Billing Document Request cannot be generated.
Resolution
1. Select the Customer from Log Details in the “Schedule Billing Document Request Creation” app.elect the Customer.
2. Find the contract with Error Status "Contains Error" filtering by Sold-To Party in the “Manage Service Contracts” app.
3. Verify the organizational data of the contract. Your customer must be created in this Sales Organization/Distribution Channel. For example, this customer must be created in Sales Organization 1710, Distribution Channel 10, Division 00.
4. Go to the "Manage Business Partner Master Data" app. Make sure that you have the “SAP_BR_BUPA_MASTER_SPECIALIST” business role to use the app.
5. Select the “Sales Area” tab and press the “Create” button.
6. Update the required fields.
7. Schedule the creation of BDR with the "Schedule Billing Document Request Creation" app. The job should be finished with the status “Success”.
Keywords
VF022 , KBA , CRM-S4-SRV-CTR , S4CRM: Service Contract , CRM-S4-SRV-BIL , S4CRM: Billing in Service Management , CRM-S4-SRV-SVO , S4CRM: Service Order , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem