SAP Knowledge Base Article - Public

2958738 - Ship-To Address Does Not Update Service Location Address as Expected After a Change

Symptom

You change the Ship-To Address in Service Order via Involved Parties tab, however, the change does not update the Service Location Address as expected.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Go to the Service Order Processing view.
  3. Search for ABC (ABC represents the Service Order ID).
  4. Navigate to the Involved Parties tab.
  5. Update the address of Ship-To party.
  6. In the General tab, the Service Location Address does not update accordingly.

Cause

The automatic update of Service Location Address does not happen because a manual change on the Service Location Address was done before.

Resolution

If you create a new quote and this is inconsistent initially, you can change the account and this will update the Ship-To and the Service Location will be changed.This is as long as you do NOT save the document.

If the document is Saved, and closed, then the session is lost for that document. This means that when you open the document and try to change the account we do not update the value.

Additionally, if you modify the service location in the involved parties, then this will not change automatically.

However, there's a possible workaround for this case:

  • You can make a dummy change in the Location of Service Provision, like change from On-Site to Supplier, then back to On-Site
  • The address will update as expected.

Keywords

Ship-To, Service Location, Address, Service Order , KBA , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign all versions