SAP Knowledge Base Article - Public

2958956 - Extension Scenario Sales Order to Customer Return is not Working as Expected

Symptom

You set up the Sales Order to Customer Return Extension Scenario. The created Customer Returns do not extend extension fields from sales orders.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Create Extension Field ABC (ABC represents the Extension field name).
  2. Setup Extension Scenario Sales Order to Customer Return on Header Level for Extension Field ABC.
  3. Create a Sales Order and Process it, with fulfilled Invoicing with Extension Field ABC containing a value.
  4. Create a Customer Return for this Sales Order.

Extension Field ABC contains no value in the customer return.

Cause

  • When creating a customer return, the reference is set to customer invoices, when a customer invoice is available.
  • When no customer invoice is available, the reference is set to the sales order.
  • The extension scenario only applies in cases, where the reference in the return is set to the sales order.
  • Only if a sales order is not invoiced (no customer invoice is created) will the Extension Scenario Sales Order to Customer Return work.

Resolution

  • This is the expected system behavior.
  • There is currently not header level extension scenario for customer invoice to customer return.
  • You can use the extension scenario on item level for customer invoice to customer return.

Keywords

Customer Return, Extension, scenario, field, Sales Order, Retoure, Kundenauftrag, Erweitungsszenario, Erweiterungsfeld, , KBA , AP-CRP-CR , Customer Return , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign 2005