Symptom
When you try to fetch Rating records from a Form using 'TrendData_SysOverallPerformance' entity, no information is shown, even though the user has an active Form linked to the current user.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SuccessFactors HXM Suite
- Integration center
- OData API
Reproducing the Issue
- Create an Integration Center job based on 'TrendData_SysOverallPerformance' entity
- Search for the User/Form raised for it
- Form will not be found
Cause
The form is missing the 'Summary Section', which consists on the ability to apply Ratings to the form. If the form does not have the Summary Section, API will not be able to fetch any information as the rating will not be available.
Resolution
Make sure that the form that you are currently trying to build has the Summary Section (as below) on it:
Note: Live forms cannot be corrected. You must follow the steps provided above to correct the template and relaunch the forms, as per KBA 2242924 - Manage Templates - Value -1972 or -1971 Appearing for Competencies or Objectives.
See Also
2242924 - Manage Templates - Value -1972 or -1971 Appearing for Competencies or Objectives
Keywords
TrendData_SysOverallPerformance not showing records on OData/Integration Center, value -1972 or -1971 Appearing for Competencies or Objectives , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , LOD-SF-PM , Performance Management , LOD-SF-INT-INC , Integration Center , LOD-SF-PM-RAT , Ratings and Weights , Problem