Symptom
- Usually names show up all on the top line of the Quickcard but it is displaying on top of itself
- The Business Phone Number is dissecting the user's name in the Quickcard
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login to the instance
- When I search for a specific user, their name is showing across two lines in the Quickcard
- The Business Phone Number of the user is splitting the name up
Cause
- The Business Phone Number is hard-coded to be shown in the top-right of the Quickcard and this cannot be changed.
- As such, if it is long enough to stretch to the user's name, it will break up the name, and cause it to display across the lower line.
Resolution
- In the screenshot in the "Reproducing the Issue" section, the country-code is down as "United States of America" whereas it should just be "+1". The country code should always be the actual code and not the country name. This adds unnecessary length to the Phone Number and will result in a case as such.
- If the user's name is long enough to stretch as far as the Phone Number, then it will also cause the name to display below and this cannot be changed.
See Also
Keywords
Business Phone Number , Quickcard , Action Search , People Search , Name , Name Split , Country Code , KBA , LOD-SF-PLT-SRH , Search , Problem
Product
SAP SuccessFactors HCM Suite all versions
Attachments
Pasted image.png |