Symptom
- Control Key PM03 Plant maintenance-External(services) is missing in S4HANA Cloud Maintenance Order ( Create , Change , Display ) App
- Is there a control key in Asset Management which can be used for plan services ( Lean ) ?
Environment
- SAP S/4HANA Cloud Public Edition
- Plant Maintenance
Reproducing the Issue
- Access the Create Maintenance Order App
- Select Order Type , for example YBA3
- Enter Planning Plant
- Press Continue
- In Work Center
- Navigate to Operation Data
- Press F4 on Control Key
- There is no entry for Control key PM03
Cause
System works as designed.
Resolution
In the SAP standard system, the following control keys are delivered for maintenance orders that are processed according to phases:
YBM1 for order operations and suboperations that are processed internally
YBM2 for order operations and suboperations that are processed externally
recommend using the control keys YBM1 and YBM2 as they are configured in the standard SAP S/4HANA Cloud solution. Changing the default configuration of these control keys or creating customer-specific control keys results in a different system behavior with regards to the phases and subphases of the phase model as well as the Has Open Main Work checkbox.
If you create customer-specific control keys, note that some settings are not supported in the processing of a maintenance order. For example, the Service indicator must not be selected. You can use lean services instead.
See Also
Keywords
External, Service, Lean service, Control key, PM03 , KBA , PM-FIO-WOC-2CL , Fiori UI for PM Maintenance Processing (Public Cloud) , PM-FIO , Fiori User Interface (UI) for PM , PM-CNT-2CL , S/4HANA Plant Maintenance Content (Public Cloud) , Problem
SAP Knowledge Base Article - Public