SAP Knowledge Base Article - Public

2961084 - Calendar Personalization in C4C

Symptom

This feature was developed to allow users to see the events in Calendar Work Center as per their personalized queries in Appointments, Phone Calls or Visits view. The primary usage for this is users to see their involvement in events, using My Involvement field within the queries.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activities work center.
  2. Go to Appointments view. Please note that this can occur in other activities view and Visits work center as well. 
  3. Go to My Appointments (queries created from these are only seen for personalization).
  4. Add extra filters and save query.
  5. Go to Calendar Work Center and Start Personalization.
  6. You shall see the created queries in drop-down upon selecting a query. The events should be displayed as per selected query.

Cause

Refresh is needed for queries to appear in drop-down of calendar upon personalization.

Resolution

Many users started using this feature with multiple fields from advanced search. See below the list of fields that can be used within the queries to personalize the calendar:

Appointment - My appointments

  • My involvement
  • Subject
  • ID
  • Document type
  • Category
  • Status
  • Priority
  • Location
  • Owner
  • Account
  • Contact
  • Organizer
  • State
  • Country/region
  • Postal Code

Phone Call - My Phone Calls

  • My involvement
  • Subject
  • ID
  • Document type
  • Category
  • Status
  • Priority
  • Location
  • Owner
  • Account
  • Organizer
  • State
  • Country/region
  • Postal Code

Visits - My visits

  • Party Role
  • Subject
  • ID
  • Status
  • Owner
  • Account
  • Organizer
  • State
  • Country/region
  • Postal Code
  • Perfect store visit
  • Visit Type

Observations

  • Date fields like Current Month, Current Year or Yesterday are not supported.
  • Complex Conditions are not allowed.
  • If a new parameter is added to an existing query, it won’t be considered - You'll have to create a new default set.
  • If user has a substitute, the results shown in the respective views and in the calendar will not match. 

See Also

SAP Help Portal: Personalize Calendar

Keywords

Calendar Personalization, Appointments, Query. , KBA , LOD-CRM-CAL , Calendar Control , How To

Product

SAP Cloud for Customer core applications 2008

Attachments

Fields+allowed+for+Personalized+que.pdf