Symptom
You cannot see results for a Technical User when accessing standard report Access Rights Change Log (Report ID CCAB03_Q001), however, you can see results for the same Technical User when accessing standard report All Current Access Rights (Report ID CCAB01_Q002).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics Work Center.
- Go to the Design Reports view.
- Search for All Current Access Rights report.
- Filter by respective Technical User.
- You can see results.
- In the Design Reports view, search for the Access Rights Change Log report.
- Filter by the same respective Technical User.
- You cannot see any results.
Cause
Access Rights Change Log report displays only those changes happened to the users which have the work center and view pair. Also, it shows the user only if there is a valid combination of changes happened to the user.
Resolution
This is the system standard behavior.
Keywords
Access Rights Change Log, All Current Access Rights, Technical User, Difference of Reports, CCAB03_Q001, CCAB01_Q002 , KBA , access rights change log , technical user , all current access rights , ccab03_q001 , difference of reports , ccab01_q002 , SRD-CC-IAM , Identity & Access Management , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To