Symptom
You want to have a workflow rule to update the "Primary Quote" field to "Yes" when creating a Sales Quote.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator Workcenter and open Workflow Rules view.
- Create a new rule and chose Sales Quote as the object.
- Define the desired schedule and conditions.
- For the action, chose "Field Update" and field "Primary Quote".
- See that the field is not available to be used in the rule.
Cause
In the Sales Quote object, there's no field for Primary Quote - It is an indicator in the Opportunity object Reference Actual Values.
It can be set or updated either manually, from the UI, or using the Sales Quote (where the indicator has exactly the name 'Primary Quote').
The logic is that, when the indicator is set or updated for a quote, the system must, at first, validate the referenced preceding opportunity. Then, it will trigger the update of the indicator in the opportunity. Hence, it's not something that a field update rule type can directly do.
Resolution
This is the expected system behavior.
Keywords
Sales Quote, Primary Quote, Workflow Rule, Field Update , KBA , LOD-LE-CQP , Customer Quote Processing , Problem