SAP Knowledge Base Article - Public

2962054 - Business Rule cannot be saved due to a Raise Message

Symptom

We have identified an application error when attempting to save a business rule with a Raise Message.

 
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Configure Business Rules.
  2. Click in the + button to create a new rule.
  3. Select the Validate HRIS Elements Scenario, fill the name of the rule and select the base object.
  4. Click Continue.
  5. Select the Raise Message action, select the message you created and the severity.
  6. Click save.
  7. Error Occurred.

         

Cause

The error message is caused by a special character, such as "", in the external code field. This is preventing the system from saving the rule.

Resolution

To resolve the error, follow these steps:

  1. Go to Manage Data.
  2. Select Message Definition and the message you added in the rule. 
  3. Take Action->Make Correction.
  4. Update the external code field so it does not have "". 
  5. Save. 
  6. Try to create the rule again. 

Keywords

cannot save rule, unable to save rule, special character, message definition, "fingerprint":"b50ca0eb3f8f86dad21c671d391994fabded5f29", "d57d0373710c3e1f35694dbb74b360c7dbce78c3", "fingerprint":"83d741787750cafe04355802a7ad1aa30b436249", "errorId":"de8ad3f3-0bf7-4315-8969-3e693e10623d", com.successfactors.rel.service.InvalidRuleExpressionException: error:Invalid input , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem

Product

SAP SuccessFactors Employee Central 2411

Attachments

Pasted image.png