SAP Knowledge Base Article - Public

2962551 - Field is missing in the dropdown in Recruit-To-Hire Mapping Tool - Recruiting/Onboarding 2.0

Symptom

  • When using the Recruit-To-Hire Mapping Tool, recruiting field from the selected template is not showing.
  • Some of the RCM fields are not visible in Recruit-To-Hire Mapping.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Onboarding 2.0

Cause

This issue could have a few different root causes. These are the ones we've identified so far:

  • Custom field is not marked as custom="true" in the template selected.
  • The field in the data model has a different data type compared to the field in the template in Recruiting (e.g.: the field fte in the data model is double while in Recruiting it is type date)
  • When using an object type field, the API Visibility of the MDF object is currently set to 'Not Visible' in the object definition.

Resolution

CAUSE 1:

If you are using custom field, it's important to mark as custom="true" in the XML template. If the field is not marked as custom="true" and is a custom field, it will not be displayed in the drop down to map the values in Recruit-To-Hire Mapping Tool. Also, do not configure a standard field ID as custom.

CAUSE 2:

The logic when mapping EC field to RCM using Recruit-To-Hire is that they should have the same data type. We cannot map a string field with number or date or picklist. To identify the Employee Central's data type, you can go to Manage Business Configuration and check the target EC field. 

If the field is configured on the template with proper data type but still does not show in Recruit-To-Hire, check if the specific field ID data type is consistent to all templates. The system will be confused what data type to display if the same field ID is configured differently per template.

For custom offer approval field that is derived from job requisition or application, it will only show in Job Offer template dropdown if the field is marked as reportable. Making the field as reportable will make it editable in Offer. For standard field ID or non-reportable custom field in Offer, you can map it directly in their source template (Job Requisition or Job Application) since these field will only appear as read only in Offer approval.

NOTE: After adding the fields, run an OData API Metadata Refresh. The instructions on how to do that are described here: 2171588 - OData API Metadata Refresh and Export in SuccessFactors Cloud.

CAUSE 3:

The Recruit-to-Hire Data Mapping feature retrieves data from the OData API Metadata. When working with an object type field, it is important to make sure that the object is editable in API.

  1. Go to Configure Object Definitions.
  2. In the 1st dropdown, select Object Definition.
  3. In the 2nd dropdown, select the object name.
  4. Click on Take Action > Make Correction.
  5. Change the 'API Visibility' to 'Editable'.
  6. Save.

After updating the object definition, please run an OData API Metadata Refresh and ensure that the Recruiting field can be found in OData API Data Dictionary.

See Also

2171588 - OData API Metadata Refresh and Export in SuccessFactors Cloud

Keywords

RCM, OBD, EC, obd 2.0, manage, pending, hires, recruits, field, unavailable, visible, selectable, template, recruiting, application, job, requisition, drop, down, select. , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-EC , Employee Central , LOD-SF-OBD , Onboarding , LOD-SF-OBX , Onboarding 2.0 , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Onboarding all versions ; SAP SuccessFactors Recruiting all versions