Symptom
You are replicating Business Partner from External System to C4C using the BusinessPartnerReplicationIn Service Interface, however the Mobile Phone number is not being updated.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Web Service Message Monitoring under Administrator Work Center.
- Search for the Message ID.
- Open the payload and you will be able to see MobilePhoneNumberIndicator as true on it.
- Go to Customers Work Center.
- Then select Account.
- Search for the ID for the Account.
- Open it.
- Go to Addresses Tab.
- Mobile Phone is blank.
Cause
The Mobile Phone number is not being updated because the Usage Code sent is AD_DEFAULT and it should be AD_MBDEFAU.
Resolution
In order to fix the issue, please check how the Mobile Phone number is maintained on the External System and make sure that you are sending AD_MBDEFAU on the Usage Code.
<Telephone actionCode="04" telephoneUsageListCompleteTransmissionIndicator="true">
<Number>
<SubscriberID>0123456789</SubscriberID>
<CountryCode>AB</CountryCode>
</Number>
<MobilePhoneNumberIndicator>true</MobilePhoneNumberIndicator>
<TelephoneUsage actionCode="04">
<Usage>
<Code>AD_MBDEFAU</Code>
</Usage>
</TelephoneUsage>
</Telephone>
See Also
Keywords
Account, Business Partner, Telephone, Number, Mobile Phone. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To