Symptom
- Exporting the report to Excel format within the Crystal 2016 or 2020 designer application may be successful.
- When the same report is published to BI Platform or Crystal Reports Server, and attempting to export the report to .xlsx format (XYZ) in a schedule or View-on-Demand, the resulting request may appear to have worked but, when you attempt to open the .xlsx file, the Excel application indicates that errors occurred while opening the file and it appears empty.
- Sheet1 of the resulting .xlsx file may be be blank. Sheet2 may contain data.
Environment
- SAP BusinessObjects Business Intelligence Platform 4.1, 4.2, 4.3 (BI 4.x)
- Crystal Reports Server 2011, 2013, 2016, 2020
- any operating system
Reproducing the Issue
- Create a Crystal Report 2016 .rpt that retrieves a considerable amount of records and generates tens of thousands of pages.
- Publish the report to BI Platform or Crystal Reports Server.
- Refresh and Export the .rpt to .xlsx format or Schedule the report to .xlsx format.
- View the resulting .xlsx file to receive the warnings/errors:
- 'We found a problem with some content in [file_name]. Do you want us to try and recover as much as we can? If you trust the source of this workbook, click Yes.'
- If 'Yes is clicked, another message appears: 'Excel was able to open the file by repairing or removing the unreadable content.'
Cause
- BI Platform or Crystal Reports Server is deployed to a Virtual Machine (VM) that has lower than minimal resourcing for a Test/Evaluation system at 8000 SAPS CPU and 16 GB RAM ratings.
- Additionally, Best Practices for Virtualizing BI Platform on VM servers were not followed by 'Strictly Reserving' CPU and memory allocations.
- For the example that helped create this KBA content, the Crystal report refreshed in CR2016 client application resulted in a .rpt that was 23000 pages+ and retrieved a total of 6.9 million records, before the export attempt to Excel.xlsx. Because of the method used to design the report, only 1.5 million records were displayed and exported.
- BI Platform Server processes perform best when there are 'Strict Reservations' for CPU and RAM. This is mentioned in chapter 3 of the Technical Whitepaper/PDF: Best Practices for Virtualizing SAP BusinessObjects BI 4.x on VMware ESXi 5
Resolution
- Ensure to follow SAP BI Platform Product Availability Matrix for meeting Minimum system Resources for a Test/Evaluation system, or higher.
- Increase CPU to at least 4 actual CPU
- Increase RAM to at least 16 GB
- Ensure that the Virtualization management options used for virtual machines do not allow CPU to be borrowed or ballooned - the VM must be configured with 'Strict Reservations' In ESX, also called: 'Resource Allocation Reservation' The 'guaranteed minimum allocation' should be set to the entire allocations for CPU and RAM. for instance, if 8 CPUs have been assigned, the 'guaranteed minimum allocation' should be 8. If 32 GB of RAM is assigned, 'guaranteed minimum allocation' should be 32.
- The same methodology applies to all types of virtualization.
See Also
Best Practices for Virtualizing SAP BusinessObjects BI 4.x on VMware ESXi 5
1994117 What is SAPS and how is it determined?
2322354 SAP BusinessObjects BI 4.1 Deployment, Sizing and Virtualization best practices
VMWare - Configuring Resource Allocation Settings: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.resmgmt.doc/GUID-14102AB7-2CF9-42E3-9642-3EB6629EF530.html
Keywords
BI, BI4, BOE, BOBJ, sap_bobj, CR, CRS, , KBA , BI-BIP-SRV , CMS / Auditing issues (excl. 3rd Party Authentication) , BI-BIP-ADM , BI Servers, security, Crystal Reports in Launchpad , BI-BIP-CRS , SAP Crystal Server , Problem
Product
Attachments
Pasted image.png |