Symptom
When creating a report through Advanced Analytics, some of the records are not being populated with the Candidate's First and Last Name.
Environment
SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- In Advanced Analytics tool, click on Data Query Tool
- Fill the data on Time, Filters and Output sections
- Click on Run
- In the report you will see some records that are missing the first and last name for the candidate.
Cause
The candidate applied directly from RCM and never came through RMK the first and last name. For that reaso they are not available to display.
Resolution
Explanation of how ATS data is joined with RMK data
Data is joined from your ATS to RMK on candidate and/or job. Candidates are joined using a two step process. The system first attempts to join on Candidate ID and if a match is not found will attempt to join on Email Address. Jobs are joined on Requisition ID.
For each record in the ATS data you provide, the system first attempts to join both the candidate and job. If a match is found they are linked. Additionally, if an Apply Start exists for that Candidate and job, the referring source of the Apply Start is also assigned to the ATS record as the "Current Referrer". Regardless of whether there is a job match, a candidate match will result in the source from which the user joined your talent community being tied to the ATS record as the "Original Referrer".
If your ATS data contains either candidates or jobs that do not exist on your RMK platform, they will be loaded to Analytics. Jobs of this nature will only contain the Requisition ID and Job Title and candidates will only contain Email Address and/or Candidate ID.
Keywords
advanced analytics, first name, last name, missing, not populating, data query tool , KBA , LOD-SF-RMK-AAN , Advanced Analytics - Professional Services , LOD-SF-RMK , Recruiting Marketing , Problem