Symptom
Job Information shows "No Data" in the Profile but when you click on History, the Job Information records are showing.
*Images/data in this KBA is from SAP Internal Systems, sample data, or Demo Systems. Any resemblance to real data is purely coincidental.*
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to the affected users's Profile.
- Scroll to Job Info and notice that it shows "No Data".
- Click on the History or Clock Icon and the Job Information is there.
Cause
The kind of issue happens when the last Job Information record has an end-date set in the past. In the above screenshot.
This kind of data issue can be caused by incorrect process of updating Job Information, end-date was set manually via Job History Import, or even data corruption.
Resolution
To verify the end-date of the last Job Information record of an affected employee:
Create an Adhoc Export Report to pull the end-date for validation:
- Go to Reporting > Ad Hoc Report > Create a New Report.
- Select "Report - Table" > "Single Domain" > "Person and Employment Export".
- In General Info tab, enter the Report Name.
- In Columns tab, click "Select Columns"
- Click Employee Information and select the following fields:
- User/Employee ID
- firstName
- lastName
- Click Employee Job Info and select the following fields:
- start-date
- end-date
- event-reason
- In the Filters tab, click "Refine Criteria".
- Click Employee Information and check "User/Employee ID".
- Select "By My Selection" and search for the affected user's User ID. Click Done.
- Click on Save and then click on Generate.
- Click on CSV to download the Report.
- Find the last record in Job Info by checking which one has the latest start-date. Then check the corresponding end-date.
Note: The end-date should always be 12/31/9999 for the last Job Information record. If it is a date in the past, this issue will occur.
Delete and recreate the last Job Information record or perform a Full Purge Import:
- Delete the last Job Information record with invalid end-date and recreate it. If you are doing this via Imports, do not enter any end-date. The system will calculate this automatically.
- If the first option does not resolve the issue, you must perform a Job History Full Purge Import.
See Also
2317955 - How to Correct or Remove Job Information Via Import in Full Purge Mode - EC
2080097 - Import Employee Data - end-date field
Keywords
no data, job information, job info, job history, end-date, job information missing, job information not displayed , KBA , LOD-SF-EC-JOB , Job Information , Problem