SAP Knowledge Base Article - Public

2963970 - Candidate reply emails are not received if original email was sent with a brand email template

Symptom

  • When a candidate replies to an email sent to them that uses a Branded Email layout, the replies are not received, neither in Message Center or in the recruiter's email. 
  • If the original email message sent from the recruiter did not include a Brand Email layout, then replies are received and visible in Message Center.

Environment

SAP SuccessFactors Recruiting

Reproducing the Issue

  1. Send the email to Candidate with brand template and brand layout.
  2. Reply to the received email.

Cause

The cause of the issue is brandEnabled field in BE_RCM_CORRES_THREAD table in the database is null when the candidate is replying to the email as it's of type Boolean so by-default it is null. And the null check for the same was missing in our code because of which NullPointerException was getting thrown and hence email was not getting sent.

Resolution

  • This issue will be fixed. The fix will provide the proper null check and make sure NullPointerException is handled.
  • The code fix is planned for B2011 release

Keywords

SF, Success Factors, RCM, brand template , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions