Symptom
Price fields are not appearing in offline mode.
Example fields "Gross Price Promotional Price" and "Gross Price Promotional Sales".
Environment
SAP Cloud for Customer
Reproducing the Issue
The fields mentioned here are examples, the same is true for other pricing fields.
- Log into the system in offline mode.
- Sync.
- Go to offline mode.
- Navigate to the Sales Order work center view.
- Open any document.
--> You are not able to find the following fields under Products table.
- Gross Price Promotional Price.
- Gross Price Promotional Sales.
Cause
The issue is that the RateChangeable flag for the condition types are set to false in the pricing customization.
For manual conditions to be visible in offline mode, the RateChangeable flag for the associated condition type must be set to true and the Manual entries priority setting must be set to one of ' '(blank)(No Limitations), 'B'(Automatic entry has priority) or 'C'(Manual entry has priority).
Also, if the RateChangeable flag is set to false, the value for the field/condition type will not be manually changeable either in C4C or ERP.
Resolution
To fix this, change the value of the RateChangeable flag to True for the relevant condition types in ERP, then download the pricing customization from there and upload it in C4C.
On changing this flag to the correct value, the fields become visible.
See Also
Keywords
KBA , LOD-CRM-PRC , C4C Pricing , LOD-LE-CQP , Customer Quote Processing , How To